Tag: Switch

VMware Switch

Microsoft’s new VMware migration offer for Windows Server 2016

Microsoft just announced a new VMware migration offer for Windows Server 2016. In a nutshell: If you switch from VMware to Hyper-V from during September 1, 2016, through June 30, 2017, you can get free Windows Server Datacenter licenses when buying Windows Server Datacenter + Software Assurance. That ultimately means customers only pay for Software Assurance.

Microsoft also released a new TCO calculator to compare VMware and Hyper-V, which you can find here: VMware Shift

There are also a lot of great technical reasons to switch from VMware to Hyper-V. Check out my blog post about What’s new in Windows Server 2016 Hyper-V to get an overview about new features.

To get started just follow these steps:

To be eligible for the VMware migration offer, customers must follow these steps:

  • Step 1: Engage your account executive or sales rep to begin the process.
  • Step 2: Identify virtualized workloads to migrate and specify the Windows Server Datacenter cores required.
  • Step 3: Provide your account executive proof of eligibility. (Offer applicable to customers migrating from VMware to Microsoft).
  • Step 4: Engage your partner to start the migration process.
  • Step 5: Receive free Windows Server Datacenter licenses with Software Assurance and pay only the cost of Software Assurance to kick start your migration.

Feel free to contact us to help you switch!



Hyper-V VM Switch

Change Hyper-V VM Switch of Virtual Machines using PowerShell

This is one of the first post of a short blog series with some simple PowerShell scripts and oneliners for Hyper-V. One this is how you can connect a Virtual Network Adapter of a Hyper-V Virtual Machine to another Virtual Switch.

This is very simple, with this command you can see all the Network Adapters of the Virtual Machine and to which Switch they are connected:

 
Get-VM "VM01" | Get-VMNetworkAdapter

With this command you can connect it to another Switch:

 
Get-VM "VM01" | Get-VMNetworkAdapter | Connect-VMNetworkAdapter -SwitchName "NewSwitch"

Now of course you can also do this for all Virtual Machines running on a Hyper-V host:

 
Get-VM | Get-VMNetworkAdapter
 
Get-VM | Get-VMNetworkAdapter | Connect-VMNetworkAdapter -SwitchName "NewSwitch"
 
Get-VM | Get-VMNetworkAdapter


Network Cisco iOS Workshop @KTSI

Small CISCO Network iOS Workshop at KTSI

Set Switch IP

Switch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#interface vlan 1
Switch(config-if)#ip address 10.123.1.254 255.255.255.0
Switch(config-if)#exit
Switch(config)#exit
Switch#wr

Port Mirroring


Switch(config)#monitor session 1 source interface fastEthernet 0/1
Switch(config)#monitor session 1 destination interface fastEthernet 0/24
Switch(config)#no monitor session 1

MAC Address Security


Switch(config)#interface fastEthernet 0/1
--->Switch(config-if)#switchport port-security mac-address sticky
Switch(config-if)#switchport mode access
Switch(config-if)#switchport port-security
Switch#show port-security

Activate Port again


Switch(config-if)#shutdown
Switch(config-if)#exit
Switch(config-if)#no shutdown

Spanning Tree


Switch(config-if)#spanning-tree portfast
Switch(config)#no spanning-tree vlan 1v

CDP deactivate


Switch(config)#no cdp run

Activate Telnet


Switch(config)#line vty 0 15
Switch(config-line)#password ktsi
Switch(config-line)#login
Switch(config-line)#transport input telnet
Switch(config-line)#transport output telnet

Webbrowser Access


Switch(config)#ip http server